Raspberry Pi 4, CaptureGrid4

Hello!

Trying to setup SmartShooter (CaptureGrid 4) on Raspbery Pi 4.
Using latest Raspberian distro.
Seting up
Snapcraft
From snapcraft Capturinggrid 4
But SmartShooter not see my cameras (Nikon D850 or Nikon D5500).

DMESG

[  912.927090] usb 1-1.4: new high-speed USB device number 7 using xhci_hcd
[  913.058844] usb 1-1.4: New USB device found, idVendor=04b0, idProduct=0438, bcdDevice= 1.02
[  913.058861] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  913.058874] usb 1-1.4: Product: NIKON DSC D5500
[  913.058886] usb 1-1.4: Manufacturer: NIKON
[  913.058898] usb 1-1.4: SerialNumber: 0000002006734

GPhoto2

[  912.927090] usb 1-1.4: new high-speed USB device number 7 using xhci_hcd
[  913.058844] usb 1-1.4: New USB device found, idVendor=04b0, idProduct=0438, bcdDevice= 1.02
[  913.058861] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  913.058874] usb 1-1.4: Product: NIKON DSC D5500
[  913.058886] usb 1-1.4: Manufacturer: NIKON
[  913.058898] usb 1-1.4: SerialNumber: 0000002006734

Capturegrid4

ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
[17:50:04.032  General     Info:  0] log file opened: /home/pi/snap/capturegrid4/31/.config/CaptureGRID 4/capturegrid4_log.txt
[17:50:04.033  General     Info:  0] date: 20/08/2019 17:50:04.033
[17:50:04.033  General     Info:  0] CaptureGRID 4 linux-arm32 v4.7
[17:50:04.048      App     Info:  0] identified OS: Linux 4.19.66-v7l+
[17:50:04.050      App     Info:  0] options loaded from: /home/pi/snap/capturegrid4/31/.config/CaptureGRID 4/capturegrid4_options.json
{
  "photoPath": "/home/pi/snap/capturegrid4/common/Pictures/CaptureGRID 4",
  "scriptFile": "/home/pi/snap/capturegrid4/common/Pictures/CaptureGRID 4/script.py",
  "applicationName": "raspberrypi",
  "sessionName": "",
  "uniqueTag": "CustomTag",
  "barcode": "",
  "barcodeCameraFilter": "",
  "customEditor": "",
  "filenameExpression": "SSP_[S]",
  "lastVersion": "v4.7",
  "defaultStorage": "Disk",
  "defaultFocusMode": "Not set",
  "defaultDisplayMode": "Recent Photo",
  "networkAddress": "",
  "networkDiscoveryMode": "Broadcast",
  "networkMulticastGroup": "239.4.6.8",
  "apiServerEndpoint": "tcp://127.0.0.1:54544",
  "apiPublisherEndpoint": "tcp://127.0.0.1:54543",
  "cameradbState": "AAAA/wAAAAAAAAABAAAAAAAAAAYBAAAAAAAAAAAAAAAAAAAAAAAAB5cAAAAbAQEBAQAAAAAAAAAAGwAAAGT/////AAAAhAAAAAMAAAAbAAAARQAAAAEAAAADAAAAQAAAAAEAAAADAAAAQwAAAAEAAAADAAAAPAAAAAEAAAADAAAAPgAAAAEAAAADAAAAQgAAAAEAAAADAAAAQAAAAAEAAAADAAAARAAAAAEAAAADAAAAWAAAAAEAAAADAAAAQAAAAAEAAAADAAAAWgAAAAEAAAADAAAAVgAAAAEAAAADAAAATQAAAAEAAAADAAAAMQAAAAEAAAADAAAASgAAAAEAAAADAAAASgAAAAEAAAADAAAAUwAAAAEAAAADAAAAVwAAAAEAAAADAAAAMAAAAAEAAAADAAAAQQAAAAEAAAADAAAAPQAAAAEAAAADAAAATwAAAAEAAAADAAAANwAAAAEAAAADAAAAQAAAAAEAAAADAAAAPwAAAAEAAAADAAAAdAAAAAEAAAADAAAAZAAAAAEAAAADAAAD6AAAAABk",
  "nodedbState": "AAAA/wAAAAAAAAABAAAAAAAAAAIBAAAAAAAAAAAAAAAAAAAAAAAABHcAAAANAQEBAQAAAAAAAAAADQAAAGT/////AAAAhAAAAAMAAAANAAAARQAAAAEAAAADAAAATAAAAAEAAAADAAAAUAAAAAEAAAADAAAAVAAAAAEAAAADAAAAYQAAAAEAAAADAAAASAAAAAEAAAADAAAATgAAAAEAAAADAAAAYgAAAAEAAAADAAAATwAAAAEAAAADAAAAYwAAAAEAAAADAAAATQAAAAEAAAADAAAAhgAAAAEAAAADAAAAZAAAAAEAAAADAAAD6AAAAABk",
  "photodbState": "AAAA/wAAAAAAAAABAAAAAAAAAA4BAAAAAAAAAAAAAAAPJAAAAAACAAAABQAAAGQAAAACAAAAZAAABbIAAAAPAQEBAQAAAAAAAAAADwAAAGT/////AAAAhAAAAAMAAAAPAAAAUwAAAAEAAAADAAAAQAAAAAEAAAADAAAAAAAAAAEAAAADAAAATQAAAAEAAAADAAAAPAAAAAEAAAADAAAAAAAAAAEAAAADAAAANQAAAAEAAAADAAAASgAAAAEAAAADAAAAVgAAAAEAAAADAAAAewAAAAEAAAADAAAAMQAAAAEAAAADAAAAbAAAAAEAAAADAAAATAAAAAEAAAADAAAAWAAAAAEAAAADAAACBQAAAAEAAAADAAAD6AAAAABk",
  "useCustomEditor": false,
  "wakeScreenSaver": true,
  "checkForUpdates": true,
  "autoConnect": true,
  "autoLoadScript": false,
  "autoSynchroniseTime": false,
  "autoScanBarcode": false,
  "filterBarcodeScanning": false,
  "resetSequenceNum": false,
  "resetSequenceNumOnEdit": false,
  "resetBatchNum": false,
  "resetBatchNumOnEdit": false,
  "enableAPI": false,
  "enableNetwork": false,
  "networkSendDiscovery": true,
  "networkDistributeOptions": false,
  "networkLiveviewConsumer": false,
  "networkPriorityMode": false,
  "showGrid": false,
  "showHistogram": true,
  "showHighlights": false,
  "showQuickLoupe": true,
  "showLiveviewQuickLoupe": false,
  "showLiveviewIndicator": true,
  "showMismatchWarning": true,
  "showCameraLostPopup": true,
  "clientPresentationMode": false,
  "networkPort": 54442,
  "networkMaxTransfers": 4,
  "networkTransferSize": 8388608,
  "nodeTimeout": 20,
  "sessionNum": 1,
  "sequenceNum": 1,
  "batchNum": 1,
  "reviewTime": 4,
  "lineHistory": 4000,
  "fontSize": 16,
  "gridRows": 10,
  "gridColumns": 10,
  "photoSpacing": 8,
  "quickLoupeSize": 20,
  "networkTransferMode": "None",
  "backgroundColour": { "red": 0.100000, "green": 0.100000, "blue": 0.100000, "alpha": 1.000000 },
  "gridColour": { "red": 1.000000, "green": 1.000000, "blue": 1.000000, "alpha": 1.000000 },
  "logLevels": {
    "Info": {
      "App": true,
      "Camera": true,
      "Database": true,
      "Example": true,
      "Font": true,
      "General": true,
      "Graphics": true,
      "Image": true,
      "Message": true,
      "Network": true,
      "Script": true,
      "Test": true
    },
    "Trace": {
      "App": false,
      "Camera": false,
      "Database": false,
      "Example": false,
      "Font": false,
      "General": false,
      "Graphics": false,
      "Image": false,
      "Message": false,
      "Network": false,
      "Script": false,
      "Test": false
    },
    "Verbose": {
      "App": false,
      "Camera": false,
      "Database": false,
      "Example": false,
      "Font": false,
      "General": false,
      "Graphics": false,
      "Image": false,
      "Message": false,
      "Network": false,
      "Script": false,
      "Test": false
    }
  },
  "sceneLayouts": [
  ]
}
[17:50:04.052      App  Warning:  0] unable to load camera presets
[17:50:04.053      App  Warning:  0] unable to load script parameters
[17:50:04.053      App  Warning:  0] unable to load camera database
qt.svg: Cannot open file '/home/pi/icons:/icons/svg/exclamation.svg', because: No such file or directory
qt.svg: Cannot open file '/home/pi/icons:/icons/svg/exclamation.svg', because: No such file or directory
qt.svg: Cannot open file '/home/pi/icons:/icons/svg/plug--arrow.svg', because: No such file or directory
qt.svg: Cannot open file '/home/pi/icons:/icons/svg/plug--arrow.svg', because: No such file or directory
qt.svg: Cannot open file '/home/pi/icons:/icons/svg/plug-disconnect-prohibition.svg', because: No such file or directory
qt.svg: Cannot open file '/home/pi/icons:/icons/svg/plug-disconnect-prohibition.svg', because: No such file or directory
QObject::connect: Cannot connect (null)::fullScreenToggled() to MainWindow::toggleFullScreen()
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
[17:50:05.791      App     Info:  0] license status: activated=false, trial=true, tag=
[17:50:05.792      App  Warning:  0] unable to load license file
[17:50:08.789      App     Info:  0] license status: activated=false, trial=true, tag=
[17:50:08.789      App     Info:  0] starting camera thread
[17:50:08.813   Camera    Error:  1] failed to open USB: -99 LIBUSB_ERROR_OTHER (Other error)
[17:50:08.814   Camera     Info:  1] detected devices: 0 new, 0 stale

Already tried to upgrade all packages…
Cant figured out whats wrong.

Thank you

Looks like something is wrong with the permissions for the CaptureGRID snap package.

[17:50:08.813 Camera Error: 1] failed to open USB: -99 LIBUSB_ERROR_OTHER (Other error)

I suspect this is an issue with Raspbian and its support for snapd, and that its not giving capturegrid the permissions it needs to use USB. I’ll have do some more investigation into this.

In the mean time, one thing to try is to install the snap in “devmode”. This will then bypass the normal permissions checks for the app. To do that:

# first remove the app
snap remove capturegrid4

# install in devmode
snap install --devmode capturegrid4

By the way, the reason that gphoto2 is not affected by this, is that its probably installed from a .deb package on the pi. That means it is not restricted in the access permissions it has to the rest of the system.

1 Like

Yes! That help!
Now it see camera and can control it.

Did i understand right that rpi version do not have liveview inside raspberian? Only as a part of grid on master?

And what correct settings to run Capturegrig4 on windows as master and raspbery as nodes.
Windows see node, but not see any cameras on it.

Yes! That help!
Now it see camera and can control it.

OK great!
And I just wanted to check, after you’ve installed the capturegrid4 snap, it will start the app automatically in the background. So, you don’t need to manually start the app. More is explained here:
https://capturegrid.com/linux.html#running-the-app

Did i understand right that rpi version do not have liveview inside raspberian? Only as a part of grid on master?
And what correct settings to run Capturegrig4 on windows as master and raspbery as nodes.
Windows see node, but not see any cameras on it.

Well, the linux snap will run (by default) without a GUI, so no you won’t be able to view the live view there. Instead, you can view it from the master node (running on windows or mac).

So on the master node, go to the “Network” tab, and enable the following options:

  • Distribute Options
  • Listen for Live View

And also, set the “Sync Photos” option as needed.
More explained here:
https://capturegrid.com/networking.html

Here the Capturegrid4 runned on Raspbery 4


even if i run with -g or without Windows stop to see rpi node.

when i start rpi as service. PC see this rpi node, but not see any cams on it :frowning:

is it possible run CG4 on Rpi with gui but as slave node?

And why windows version can’t see cams on rpi? Can this be from license issues, trial is expired.

First thing I wanted to check with you, on the linux node, did you stop the capturegrid4 background service? Remember, after installing the snap package, the app will be automatically started and run as a service in the background. So if you later want to run the app yourself, you need to stop this first with:

snap stop capturegrid4

is it possible run CG4 on Rpi with gui but as slave node?

Yes definitely, actually this is what you are doing, when you manually launch the app.
The only difference between the background service, is that it gets run with the --cli option, so that no GUI is shown.

Thanks for the screenshots. Whats odd is the Windows screenshot, it shows the “local” node as disconnected - is the app running in trial mode, or maybe the trial mode has run out?

Trial run out. But your license you sent me for tests is not working in Grid version.

Ah ok, I’ve emailed you another test license to use.

Perfect! Now Windows see raspbery pi node and cameras on it.

But now i have problem with Sony a6500 cam.
For windows i use Remote Control mode on a6500 and Capturegrid see my camera, can download images, can shot and do autofocus.
But when i try to connect to rpi it always show “Connecting” and Capturegrid not see camera.
If i switch to MTP on camera, Capturegrid see a6500 but no reaction from buttons, or from “Shoot” button on Capturegrid.

Any ideas what to test?

Let me check here first, and verify everything is working correct on linux for the Sony camera support.

@vlad to confirm, I’m also seeing the same issue with the Sony a6500 on the linux version of CaptureGRID. I’ll let you know once I’ve fixed this.

1 Like

@vlad which linux platform are you running?
I have a possible fix to try out, just wanted to check whether you need an intel, arm32, or arm64 build?

Raspbery pi v4 and 2019-07-10-raspbian-buster-full

I’ve uploaded a test version of the snap package, to the “edge” channel.
It hopefully fixes this issue with the Sony cameras.

To test it out, if you already have the snap installed, then switch to the “edge” channel with this command:

snap refresh --channel edge capturegrid4

Otherwise, install like this:

snap install --channel edge capturegrid4
1 Like

PC-Remote working now with Sony a6500 (i hope Sony a7III/a7RIII too)!

But only after uninstall and install back as devmode.

snap install --devmode --channel edge capturegrid4

Thank you!