SD Card required to download images to the computer and not on the card?

Howdy howdy!

I’ve been experimenting with other multiple camera rig software and while trialing out Grid4 (loving it so far), I noticed that I am unable to download any pictures from a camera that have no SD card in the camera

The other software that I’ve been using was able to download images shot from the camera to my computer, without an SD card attached in it.

I’ve experimented and toggled multiple storage settings to see if other cameras with SD card would trigger the camera without and SD card to download to the computer, but no luck.

I’ve been experimenting with other multiple camera rig software and while trialing out Grid4 (loving it so far)

Great, that’s good to hear!

Regarding this issue with cardless camera operation, it should be working.

And you shouldn’t have to do anything special, just take out the SD card, power on the camera, connect to it in CaptureGRID, and then set the Storage mode to Disk.

Then when you take a photo, the photo will be downloaded directly from the camera’s memory buffer and saved to the computer hard disk.

But note. some much older Canon/Nikon DSLRs did not support this, such as the Nikon D5000.
And also all models in the Nikon D3xxx range do not support this.

What model of camera are you using?

Thanks for the reply!

I’m using Canon Rebel SL3 that came out a few months ago.

I’ve done as you explained, but still no image is being downloaded to the computer and this goes the same for Canon 6D mark 2 model as well.

Can you check if you have any other software running on the computer, that could also be trying to communicate with the camera?

That includes Canon’s own EOS utility, or perhaps, some other tethering software, or Lightroom.

From your description, it sounds like CaptureGRID is not receiving any event messages from the camera, and this could be because they are getting lost to some other app.

Actually please disregard my previous post!

This is issue is NOT to do with interference from other software.

I’ve just been debugging against the SL3, and it turns out that this camera is incorrectly reporting the storage modes that it supports. Canon cameras have a property to control the storage location, and this can normally be set to either “SDCard”, “Disk”, or “SDCard+Disk”.

But with the SL3 camera, even though there is no SD card in the camera, it is reporting to CaptureGRID that it supports only the “SDCard” storage location.

I suspect this issue could affect other Canon cameras, such as the 6D Mark II.
For the cameras I normally test against, I’ve not noticed this before.

But now, hopefully I can add a work-around in software to fix this.

Checked and have nothing extra running besides Grid4.

Restarted computer and repeated the previous process and still no luck.

I’ve now fixed this issue, it will be working again in the next update.

If you want to try it out sooner, use this test version:

Hey Francis it works! Thanks for the fast fix on this!

1 Like