Mind the cables!

I struggled until the night yesterday to get my Sony 7RIV to tether.
No way. The camera was not detected even though I could see it on LightRoom.
I tried turning them on and off, and changing cables and settings. Losing hope, I unplugged the connector, turned it 180°, the text OWC facing me, plugged it in again, and changed the other end text upward to the second Thunderbolt hole on my MacAir M2.
I will probably buy this SW once the test period is over.

I had the same issues with a Nikon Z 7 II but didn’t try your solution. Now I’m way past the free trial so it’s a bit late for me but I’m happy for you! :yum:

Glad to hear you are up and running. That behavior could indicate that one or more of the pins in the cable are not functioning properly for some reason. It might be wroth testing the setup with a different cable and/or testing the cable with a different USB-C device to see if you experience the same behavior.

Also, if you haven’t done so already, it is advised to turn off USB Power Supply in the camera menu if you are experiencing connection issues. So that might be another thing to look at.

In any case, glad to hear you are up and running!

I I get a lot of these cable problems. It seems that the thunderbolt is not quite yet there. Now I ordered some expensive good quality cables from overseas. I hope this Unnecessary back-and-forth finally is enough.

The super heavy cable from TetherTools arrived.
No connection.
Out of my five USB-3 and USB-4 cables there is only one that is able to connect.
How do you explain that? They are doing OK in other uses. I have a Thunderbolt HD and a Thunderbolt screen with no problems.
Could it be my camera? I did a hard reset of no avail.
To sum it up, I cannot take this setup for a shoot.
I’ll try the Wi-Fi connections now.

I bet you knew it already: Direct Wi-Fi wants a password that is supposed to be in the “Info” file on your SD card. Nothing there, It must be classified information. With the contact point it found my router but despite indicating ongoing Wi-Fi connection, it remained mute.
Having tried all the possibilities on two Macbook Airs (M1 & M2) five different USB-3 and 4 cables and getting and not getting contacts at random, I’ll do my tethering with an iPhone from now on.
I had the setup working fro two hours but the next day with the same settingg, black screen.
It could be My Sony A7 RIV. Should I buy a new camera? What if it does not help?

If you reach out to techsupport@tethertools.com, we would be able to extend the trial for a few days if you’d like to test this out.

If multiple cables are producing the same result, it likely is either a computer or camera issue. Please double-check your camera settings to ensure that it is set up for tethering. These are the settings that we recommend for the Sony a7R IV (please note the Power Delivery setting in particular):

(Network - 1/3) → Ctrl w/ Smartphone OFF
(Setup - 4/7) → USB Power Supply OFF
(Setup) → USB Connection MTP
(Setup) → USB LUN Setting Multi (Normally Multi would be used, Single only if connection is not available)
(Network - 1/3) → PC Remote Function (1/3) →
PC Remote:
PC Remote Function (Network1 - 1/3)
PC Remote Cnct Method:

Also, please be sure that there is no software running in the background. In particular, please be sure that Google Drive and Dropbox are not running in the System Tray / Menu Bar.

Hope that helps.

Well that’s weird. I couldn’t get this to work on my trial period. I just happen to have an OWC cable also so I simply turned it around and viola! it worked.

I had the Google Drive running. I turned it off and got connection at least once.
The USB4/Thunderbolt has bad karma. I hope your luck will last.