CaptureGrid4 on Windows 10 and cameras connected with RPi

Hello, after an unsuccessful quest to connect 40+ Canon cameras to Windows PC using USB hubs and cables, now I am trying other method. As explained in CG4 wiki, I have downloaded and flash the capturegrid_pi4_v4_22.img.xz file into RPi cards. Then, I connected cameras to RPi, however, CG4 on Windows is unable to find any nodes in Network tab. I have set Windows PC network mode to “Master” and checked “Enable network connection”. Everything is done like said “Insert the card into the computer, connect power and network cables, and USB cable to the cameras.”
I don’t understand what is wrong with my setup. I hope it is possible to control cameras from a Windows 10 PC when using RPi model 4.
Note: I am using CG4 licensed version.

Mostly likely this is a networking issue, so unfortunately it can be hard to diagnose!

A few of things to check:

  • Are the RPi’s connected via ethernet to the same local network as the Windows PC?
  • Is there a DHCP server (on your router or whatever) so that each RPi can get a IP address?
  • After first boot from a new flash, the RPi may take serveral minutes to do initial configuration; so it may take 10+ minutes until they are up
  • On the Windows PC, does the CaptureGRID app have permissions to send/receive network data? Windows built-in firewall may have blocked this. Windows should present a popup window when the app first opens a network port, prompting you to allow/disallow network access.

In the CaptureGRID app on the Windows PC, check these setting in the “Network” tab:

  • Interface - has the app selected the correct network interface (IP address)? If not, try changing this from the drop down menu
  • Discovery mode - this controls how the discovery messages are broadcast out over the network, which each RPi will be listening for; try changing this option to see if it makes a difference

Hi @francis, thank you for your response.
Actually, the problem seems to be with captureGrid IMG file downloaded and flashed to the memory cards. Later, I tried manually installing the Raspbian Lite OS and captureGrid which worked fine. Now I can find raspberry pi nodes in the network tab with cameras attached.
I am still working on the project and tomorrow I will be able to connect all 40 cameras. I will update here if something doesn’t work.